You are not logged in.

#1 2017-04-25 10:20:26

kroogy
Member
Registered: 2017-04-25
Posts: 3

LVM wrong path /dev/mvgvol

Hello,

I want to install arch on a LVM volume (/dev/mvg/archany).
The installer work on path /dev/mvgarchany...
So the mount is impossible: /dev/mvgarchany is not existing...

I use arch-anywhere-2.2.7-1-dual.iso, and I have execute "arch-anywhere -u"

kroogy@melon ~ % lsblk 
NAME            MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda               8:0    1 698,7G  0 disk 
├─sda1            8:1    1  47,7G  0 part /run/media/kroogy/WIN_SYS_47G
├─sda2            8:2    1   125M  0 part /boot
├─sda3            8:3    1   151G  0 part 
│ ├─mvg-swap    254:0    0     3G  0 lvm  
│ ├─mvg-arch    254:1    0    20G  0 lvm  /
│ ├─mvg-home    254:2    0    50G  0 lvm  /home
│ └─mvg-archany 254:3    0    77G  0 lvm  
├─sda4            8:4    1     1K  0 part 
└─sda5            8:5    1 499,8G  0 part /run/media/kroogy/WIN_499G

xiNgSeo.jpg
07N68bn.jpg
2brZxts.jpg

Last edited by kroogy (2017-04-25 10:28:30)

Offline

#2 2017-04-25 15:25:10

kroogy
Member
Registered: 2017-04-25
Posts: 3

Re: LVM wrong path /dev/mvgvol

I search  a little bit by myself...

in the configure_device.sh file, I found the line 390:

device_list=$(lsblk -nio NAME,SIZE,TYPE,FSTYPE | egrep -v "$USB|loop[0-9]+|sr[0-9]+|fd[0-9]+" | sed 's/[^[:alnum:]_., ]//g' | column -t | sort -k 1,1 | uniq)

The result for me is wrong:

mvgarch     20G     lvm   ext4
mvgarchany  77G     lvm   ext4
mvghome     50G     lvm   ext4
mvgswap     3G      lvm   swap
sda         698,7G  disk
sda1        47,7G   part  ntfs
sda2        125M    part  ext2
sda3        151G    part  LVM2_member
sda4        1K      part
sda5        499,8G  part  ntfs
sr0         1024M   rom

I think the error was in this line..

Last edited by kroogy (2017-04-25 15:25:34)

Offline

#3 2017-05-08 11:13:03

kroogy
Member
Registered: 2017-04-25
Posts: 3

Re: LVM wrong path /dev/mvgvol

Is it fix in a next release ?

Offline

Board footer

Powered by FluxBB