You are not logged in.

#1 2017-06-04 01:33:29

Registered: 2017-06-04
Posts: 1

TRIM Support

Hi everyone, coming from Antergos here.

While looking through the Antergos forum while I used Antergos there were a couple of posts where maintainers would say that TRIM is automatically enabled and that we as users did not need to worry about it.

Now my installation is different, I decided to move from Antergos to Arch (via Arch anywhere). I have one SSD (512 GB) mounted as / and one HDD (750GB) mounted as /home. I was looking at the Arch Wiki on enabling TRIM. Unfortunately, enabling the fstrim service would return this.

# systemctl enable fstrim.service
The unit files have no installation config (WantedBy, RequiredBy, Also, Alias
settings in the [Install] section, and DefaultInstance for template units).
This means they are not meant to be enabled using systemctl.
Possible reasons for having this kind of units are:
1) A unit may be statically enabled by being symlinked from another unit's
   .wants/ or .requires/ directory.
2) A unit's purpose may be to act as a helper for some other unit which has
   a requirement dependency on it.
3) A unit may be started when needed via activation (socket, path, timer,
   D-Bus, udev, scripted systemctl call, ...).
4) In case of template units, the unit is meant to be enabled with some
   instance name specified.

I am not sure what to do here. Thanks!


#2 2017-07-07 17:03:37

Registered: 2017-02-05
Posts: 5

Re: TRIM Support

For Trim on Arch you want to be running fstrim.timer which will automatically execute trim on a weekly basis (in real os time). Just run the command:

sudo systemctl start fstrim.timer

then run:

sudo systemctl enable fstrim.timer

That's it, never worry about trim again. You can also periodically check the status of the trim timer and when it was last run along with when it'll be run again by running

systemctl status fstrim.timer

Last edited by annoyingduck (2017-07-07 17:06:06)


Board footer

Powered by FluxBB